별의 공부 블로그 🧑🏻‍💻
728x90
728x170

문제

Uniform Resource Identifiers (or URIs) are strings like http://icpc.baylor.edu/icpc/, mailto:foo@bar.org, ftp://127.0.0.1/pub/linux, or even just readme.txt that are used to identify a resource, usually on the Internet or a local computer. Certain characters are reserved within URIs, and if a reserved character is part of an identifier then it must be percent-encoded by replacing it with a percent sign followed by two hexadecimal digits representing the ASCII code of the character. A table of seven reserved characters and their encodings is shown below. Your job is to write a program that can percent-encode a string of characters.


CharacterEncoding
" " (space)%20
"!" (exclamation point)%21
"$" (dollar sign)%24
"%" (percent sign)%25
"(" (left parenthesis)%28
")" (right parenthesis)%29
"*" (asterisk)%2a

 

 

입력

The input consists of one or more strings, each 1–79 characters long and on a line by itself, followed by a line containing only "#" that signals the end of the input. The character "#" is used only as an end-of-input marker and will not appear anywhere else in the input. A string may contain spaces, but not at the beginning or end of the string, and there will never be two or more consecutive spaces.

 

 

출력

For each input string, replace every occurrence of a reserved character in the table above by its percent-encoding, exactly as shown, and output the resulting string on a line by itself. Note that the percent-encoding for an asterisk is %2a (with a lowercase "a") rather than %2A (with an uppercase "A").


 

예제 입력

 Happy Joy Joy!

 http://icpc.baylor.edu/icpc/

 plain_vanilla

 (**)

 ?

 the 7% s

 

예제 출력

 Happy%20Joy%20Joy%21

 http://icpc.baylor.edu/icpc/

 plain_vanilla

 %28%2a%2a%29

 ?

 the%207%25%20solution

 

 

힌트

 

 

출처

ACM-ICPC > Regionals > North America > Mid-Central Regional > 2007 Mid-Central Regional Programming Contest B번 

 

 

링크

 

 

코드

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#include <iostream>
#include <cstring>
#define N 80
 
using namespace std;
 
int main()
{
    char input[N];
    int len;
 
    while (1) {
        cin.getline(input, N);
        len = strlen(input);
 
        if (input[0== '#') {
            return 0;
        }
 
        for (int i = 0; i < len; i++) {
            if (input[i] == ' 'cout << "%20";
            else if (input[i] == '!'cout << "%21";
            else if (input[i] == '$'cout << "%24";
            else if (input[i] == '%'cout << "%25";
            else if (input[i] == '('cout << "%28";
            else if (input[i] == ')'cout << "%29";
            else if (input[i] == '*'cout << "%2a";
            else cout << input[i];
        }
        cout << endl;
    }
 
    return 0;
}
cs

728x90
그리드형(광고전용)
⚠️AdBlock이 감지되었습니다. 원할한 페이지 표시를 위해 AdBlock을 꺼주세요.⚠️
starrykss
starrykss
별의 공부 블로그 🧑🏻‍💻


📖 Contents 📖